Verwendung: Neues Icon ist im Picker, kann aber nicht über CSS-Klasse zugewiesen werden

Martin's Avatar

Martin

09 Nov, 2021 10:00 AM

Produkt: Tao Contao
Contao-Version: 4.9.14

Hallo,

ich verwende zum ersten Mal die Icon-Anpassung, die hier auf der Seite auch sehr gut dokumentiert ist. Das neue Icon ist im Picker zu sehen und kann zugewiesen werden, wenn ich ein entsprechendes Modul nutze. Aber das in Tao bereits vorkonfigurierte Zuweisen als Icon vor einem Navigationspunkt via bspw. icon-3d im Seitenelement klappt weiterhin nur mit den default Icons. In meinem Screenshot sieht man das vorkonfigurierte "3d", das in der CSS-Klasse auch zugewiesen werden kann. Wenn ich aber icon-stuhl eintrage, klappt das nicht obwohl "stuhl" der Name für die CSS-Klasse dieses Icons ist. Funktioniert das mit dem vorkonfigurierten Tao nur, wenn man Icons ersetzt?

  1. 1 Posted by Martin on 09 Nov, 2021 10:56 AM

    Martin's Avatar

    Das Problem ist leider aus meiner Sicht noch etwas komplizierter. Ich habe soeben auch das Ersetzen eines Icons probiert. Unter dem Namen "anchor" sollte jetzt ein anderes Bild zu sehen sein. Das neue Vorschaubild sehe ich auch im Picker, wo vorher der Anchor war, aber das eigentliche Icon wird sowohl in Icon-Boxen als auch in der Navigation, wenn ich class-anchor eintrage, nicht angezeigt. Es erscheint weiterhin das Symbol mit dem Anker. Beim oben beschriebenen neuen Icon "stuhl" kann ich das neue Symbol in Icon-Boxen zum Anzeigen bringen, nicht aber in der Navigation, wenn ich icon-stuhl eintrage. Ich habe dann mal im Quellcode nachgesehen, wie das neue Symbol in der Icon-Box gecodet ist. Da steht: data-icon="" Leider kann ich mit e900 nichts in der CSS-Klasse bewirken. Da greift offenbar nur der "name", der aber irgendwie nicht zugeordnet wird. Gibt es vielleicht doch noch einen Schritt, der in der Doku fehlt oder den ich übersehen habe. Habe alle vier Dateien unter /fonts in rocksolid-icons umbennannt. Zudem auch die style.css entsprechend umbenannt und in /fonts kopiert. Die html-Datei gleichen Namens habe ich wie in der Doku beschrieben gelöscht.

  2. 2 Posted by Martin on 09 Nov, 2021 01:36 PM

    Martin's Avatar

    Hat sich erledigt! Hab doch noch einen vergleichbaren Fall gefunden:

    https://help.rocksolidthemes.com/discussions/contao/24726

    Es lag daran, dass ich das neue Logo auch in der icons.css anlegen musste. Ich meine, das stand nicht in der Doku. Oder ich habe es überlesen. Aber jetzt wird das neue Icon in der Navi angezeigt.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • icon-problem.jpg 18.5 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac