Installation: Contao-Fehlermeldung Strict Mode

Jens Reichel's Avatar

Jens Reichel

27 Sep, 2021 08:25 AM

Liebes DF-Team,

meine mit TAO erstellte Firmenwebsite läuft schon lange prima.

Nun möchte ich unter einer anderen Domain eine neue Website erstellen. Hierfür habe ich wie gewohnt Contao installiert, erhalte vom Installtool jedoch folgende Meldung:

Ihr Datenbank-Server läuft nicht im Strict-Mode!

Wenn MySQL nicht im Strict-Mode läuft, können Daten beschädigt oder abgeschnitten werden. Bitte aktivieren Sie den Strict-Mode entweder in Ihrer my.cnf-Datei oder konfigurieren Sie die Verbindungsoptionen in der Datei config/config.yml wie folgt:

doctrine:
    dbal:
        connections:
            default:
                options:
                    1002: "SET SESSION sql_mode=(SELECT CONCAT(@@sql_mode, ',TRADITIONAL'))"

Contao scheint dennoch zu funktionieren, aber natürlich habe ich Sorge, dass das nach einer umfangreichen Erstellung irgendwann nicht mehr der Fall sein könnte.

Was mich verwundert: Bestehender und neuer Webspace haben dieselben Contao-Versionen und PHP-Einstellungen. Das Installtool für den bestehenden Webspace meckert nicht, das für den neuen schon. Meinen Provider habe ich bereits kontaktiert, der kann sich darauf auch keinen Reim machen.

Danke für Ihre Unterstützung!

  1. Support Staff 1 Posted by RockSolid Theme... on 27 Sep, 2021 09:53 AM

    RockSolid Themes's Avatar

    Vielen Dank für Ihre Frage.

    Bei der Strict-Mode-Meldung handelt es sich nicht um eine Fehlermeldung, sondern um eine Warnung.

    Contao scheint dennoch zu funktionieren, aber natürlich habe ich Sorge, dass das nach einer umfangreichen Erstellung irgendwann nicht mehr der Fall sein könnte.

    Sie können die Meldung beseitigen indem Sie den Strict-Mode entweder in Ihrer my.cnf-Datei aktivieren oder die Verbindungsoptionen in der Datei config/config.yml konfigurieren.

    Was mich verwundert: Bestehender und neuer Webspace haben dieselben Contao-Versionen und PHP-Einstellungen. Das Installtool für den bestehenden Webspace meckert nicht, das für den neuen schon.

    Diese Meldung existiert erst seit Contao 4.9.20.

  2. 2 Posted by Jens Reichel - ... on 27 Sep, 2021 10:17 AM

    Jens Reichel - DistincTravel's Avatar

    Vielen Dank für die schnelle Antwort!

    Die Datei my.cnf kann ich laut meinem Provider nicht editieren.

    Ich finde in meinem Webspace zwei config-Verzeichnisse:

    /config
    /system/config

    Da ich nicht wusste, welches das richtige ist, habe ich in beiden eine Datei config.yml mit folgendem Inhalt angelegt:

    doctrine:
        dbal:
            connections:
                default:
                    options:
                        1002: "SET SESSION sql_mode=(SELECT CONCAT(@@sql_mode, ',TRADITIONAL'))"

    Ich habe auch versucht, 1002 durch 3 zu ersetzen.

    In beiden Fällen gibt das Installtool weiterhin die Warnung bezüglich des Strict-Mode aus.

    Haben Sie noch einen Tipp, was ich bei der Erstellung der config.yml falschgemacht habe bzw. wo sie liegen muss?

    Oder kann ich die Warnung getrost ignorieren, weil sie auch zukünftig für den stabilen Betrieb von Contao bzw. RockSolid Themes ohne Belang ist?

    Nochmals danke!

    Jens Reichel

  3. Support Staff 3 Posted by RockSolid Theme... on 27 Sep, 2021 02:40 PM

    RockSolid Themes's Avatar

    Bitte leeren Sie den Anwendungs-Cache über den Contao-Manager nachdem Sie die Konfiguration angepasst haben.

    Der korrekte Pfad zur Datei lautet config/config.yml

    Weitere Informationen zu diesen Einstellungen finden Sie in der Dokumentation von Contao: https://docs.contao.org/manual/de/installation/systemvoraussetzungen/#mysql-mindestanforderungen

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac