Probleme mit install.php

Horst's Avatar

Horst

28 Feb, 2013 09:47 AM

Hallo,
habe gestern contao3.04 installiert, dann das Theme 80/20, alles prima geklappt. Als ich dann versucht habe, das zugehörige Template zu importieren, bekam ich immer die Fehlermeldung "Falsches Passwort". Habe dann $GLOBALS['TL_CONFIG']['installCount'] = 0; gesetzt. Wieder die gleiche Fehlermeldung.
Habe dann $GLOBALS['TL_CONFIG']['installPassword'] herausgenommen. Nun bekam ich die Aufforderung ein neues Passwort einzugeben, habe ich auch korrekt gemacht, bekam dann aber auch wieder eine lange Fehlermeldung. Habe sie leider nicht gespeichert.

Was kann ich machen, dass ich über install.php mein Template importieren kann?

  1. Support Staff 1 Posted by RockSolid Theme... on 28 Feb, 2013 12:49 PM

    RockSolid Themes's Avatar

    Vielen Dank für Ihre Frage.

    Die Version 3.0.4 von Contao enthält einen Fehler im Installtool, weitere Informationen dazu finden Sie hier: https://github.com/contao/core/issues/5384

    Der Fehler ist in der aktuellen Contao-Version 3.0.5 bereits behoben. Nachdem Sie Contao aktualisiert haben, sollte der Template-Import wieder korrekt funktionieren.

  2. RockSolid Themes closed this discussion on 28 Feb, 2013 12:49 PM.

  3. Horst Manschus re-opened this discussion on 28 Feb, 2013 03:57 PM

  4. 2 Posted by Horst Manschus on 28 Feb, 2013 03:57 PM

    Horst Manschus's Avatar

    Habe jetzt Conto 3.0.4 installiert. Das Theme 80/20 habe ich auch installiert.
    Frage 1: Muss ich auf 3.0.5 updaten, um das Template mit install.php importieren zu können?
    Frage 2: Was ist das Passwort für das install.php, woher bekomme ich das? Ist es das Passwort der Datenbank?
    Frage 3: Kann ich das Template importieren mit einer früheren Version z. B. 3.0.1?

    Wenn nur mit 3.0.5:
    Live Update auf 3.0.5 ist noch nicht möglich.
    Habe Version 3.0.5 heruntergeladen und entpackt.
    Wie kann ich nun manuell updaten? Bitte um Erklärungen, die auch ein Conto-Neuling verstehen kann.

  5. Support Staff 3 Posted by RockSolid Theme... on 28 Feb, 2013 04:10 PM

    RockSolid Themes's Avatar

    Zu 1: Da die Version 3.0.4 fehlerhaft ist, müssen Sie entweder auf 3.0.5 updaten oder auf 3.0.0 bis 3.0.3 downgraden

    Zu 2: Das Install-Tool-Passwort wird beim ersten Aufruf von Ihnen selbst vergeben. Falls Sie es vergessen haben können Sie hier nachlesen wie es zurückgesetzt werden kann: https://contao.org/de/faq/ich-habe-das-passwort-fuer-das-installtoo...

    Zu 3: Wie in Punkt 1 beschrieben können Sie auch auf Contao 3.0.0 bis 3.0.3 das Template importieren.

    Für weitere Fragen beachten Sie bitte dass wir nur Anfragen bearbeiten können, die direkt mit RockSolid Themes zu tun haben. Für allgemeine Fragen zu Contao oder Individualisierungen können wir folgende Quellen als hilfreich empfehlen:

    http://www.contao-community.de/
    http://de.contaowiki.org/
    http://contao.org/de/users-guide.html
    http://www.contao-handbuch.de/buchindex.html

    Literaturtipps:

    Websites erstellen mit Contao 3 von Peter Müller:
    http://rst.io/buchtipp-websites-erstellen-contao

    Das Contao Praxisbuch von Daniel Koch:
    http://rst.io/buchtipp-contao-praxisbuch

    Contao für Redakteure von Nina Gerling:
    http://rst.io/buchtipp-contao-fuer-redakteure

    Mit Contao Webseiten erfolgreich gestalten von Thomas Weitzel:
    http://rst.io/buchtipp-contao-websites-erfolgreich

  6. RockSolid Themes closed this discussion on 28 Feb, 2013 04:10 PM.

  7. Horst Manschus re-opened this discussion on 28 Feb, 2013 04:23 PM

  8. 4 Posted by Horst Manschus on 28 Feb, 2013 04:23 PM

    Horst Manschus's Avatar

    Hallo,

    nichts für ungut, aber ich habe hier ein Theme mit dem dazugehörigen Template gekauft.
    Das möchte ich einfach nur installieren können, die Installation, so wie sie hier im Video so toll beschrieben wird, funktioniert nicht.

    Zu ihrer Antwort:
    Das von mir zuerst eingegeben Passwort nach der Erstinstallation war "contao". Das wurde nicht akzeptiert.
    Die von ihnen vorgeschlagene Änderungen habe ich auch schon durchgeführt, konnte auch ein neues Passwort eingeben und bestätigen. Als ich den Vorgang abschliessen wollte, bekam ich eine lange Fehlermeldung.

  9. Support Staff 5 Posted by RockSolid Theme... on 28 Feb, 2013 04:53 PM

    RockSolid Themes's Avatar

    Wie bereits in der ersten Antwort angemerkt enthält Contao 3.0.4 einen Fehler im Installtool. Dieser Fehler hängt nicht mit unseren Themes bzw. Templates zusammen.

    Die einfachste Lösung ist eine Neuinstallation von Contao 3.0.5, mit der Sie Ihr Theme der Video-Anleitung entsprechend installieren können.

  10. RockSolid Themes closed this discussion on 28 Feb, 2013 04:53 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac