Installation: Wechsel auf PHP 7.2 mit TAO funktioniert nicht.

Michael Löffler's Avatar

Michael Löffler

11 Jul, 2018 09:05 PM

Produkt: Tao Contao
Contao-Version: 3.5.35
Browser und Browserversionen: IE und Firefox

Hallo

Ich versuche auf PHP 7.2 zu wechseln, doch leider funktioniert es nicht. Meine Version läuft nur mit Version PHP 5.6. ich habe die Datenbank auf MySQLi angepasst, dazu auf Version 3.5.35 gewechselt, doch ich erhalte immer noch die folgende Fehlermeldung:

Fatal error: Cannot use 'String' as class name as it is reserved in /home/kampfkun/public_html/zumba-shop/system/modules/core/library/Contao/String.php on line 28

Wie und was muss ich ändern, damit ich PHP 7.2 verwenden kann ?

In der Zwischenzeit gehe ich wieder zurück auf PHP 5.6, dass die Website online und verfügbar ist.

Besten Dank und freundliche Grüsse
Michael Löffler

  1. 1 Posted by Michael Löffler on 11 Jul, 2018 09:27 PM

    Michael Löffler's Avatar

    Hallo zusammen

    Es funktioniert doch soweit. Ich hatte vergessen alle Erweiterungen noch zu aktualisieren. Nun geht es einwandfrei mit PHP 7.2.

    Vielen Dank und Grüsse
    Michi Löffler

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac